Quantcast

cosbench failed to start on debian Jessie

classic Classic list List threaded Threaded
4 messages Options
sky
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

cosbench failed to start on debian Jessie

sky
when i review back log/libs.log

show bellow...
2015-08-11 03:35:29,225 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/j2ee_1_4.xsd
2015-08-11 03:35:29,302 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/xml.xsd
2015-08-11 03:35:29,303 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/jsp_2_0.xsd
2015-08-11 03:35:29,304 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/jsp_2_1.xsd
2015-08-11 03:35:29,305 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/web-jsptaglibrary_1_1.dtd
2015-08-11 03:35:29,407 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/web-jsptaglibrary_1_2.dtd
2015-08-11 03:35:29,407 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/web-jsptaglibrary_2_0.xsd
2015-08-11 03:35:29,408 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/jsp/resources/web-jsptaglibrary_2_1.xsd
2015-08-11 03:35:29,409 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/web-app_2_2.dtd
2015-08-11 03:35:29,467 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/web-app_2_3.dtd
2015-08-11 03:35:29,502 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/web-app_2_4.xsd
2015-08-11 03:35:29,503 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/web-app_2_5.xsd
2015-08-11 03:35:29,503 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/j2ee_web_services_1_1.xsd
2015-08-11 03:35:29,504 [WARN] [Timer-0] org.apache.catalina.startup.DigesterFactory - Could not get url
for /javax/servlet/resources/j2ee_web_services_client_1_1.xsd

can somebody help to tell me how to solve this problem(could not get url)?

i already try to follow BUILD.md step to create own plugin... but failed too

everytime i use sh start-all.sh

Launching osgi framwork ...
Successfully launched osgi framework!
Booting cosbench driver ...
invalid interval time 0
.invalid interval time 0
.invalid interval time 0
.invalid interval time 0
.invalid interval time 0
...

and never stop till end with result invalid interval time 0 ...

i try stop and use ps aux |grep java and kill the process ...
then i directly use command below:
~$ java -Dcosbench.tomcat.config=conf/driver-tomcat-server.xml -server -cp main/org.eclipse.equinox.launcher_1.2.0.v20110502.jar org.eclipse.equinox.launcher.Main -configuration conf/.driver -console 18089 &

and

~$ java -Dcosbench.tomcat.config=conf/controller-tomcat-server.xml -server -cp main/org.eclipse.equinox.launcher_1.2.0.v20110502.jar org.eclipse.equinox.launcher.Main -configuration conf/.controller -console 19089 &

the web-UI  look not problem ... but i can run any test for my ceph cluster ...


here my system info :


java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-1)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

==========
eclipse version 3.8

==========
 curl 7.43.0

==========

3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt2-1 (2014-12-08) x86_64 GNU/Linux

Thanks,

Sky
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cosbench failed to start on debian Jessie

ywang19
Administrator
do below change on "cosbench-start.sh" should fix it:
    TOOL_PARAMS="-i 0"  
-->
    TOOL_PARAMS="-i 1"
sky
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cosbench failed to start on debian Jessie

sky
Hi, ywang~
after change to -i 1 , will i run start-all.sh
it shows bellow :
 
Booting cosbench driver ...
(UNKNOWN) [0.0.0.0] 18089 (?) : Connection refused

i guess that because the java haven't complete starting on port 18089 。。。
so i change then sleep 1 -> sleep 5
but now stuck on here

Launching osgi framwork ...
Successfully launched osgi framework!
Booting cosbench driver ...

so it look like still can’t fix the problem while using shell script to start up ...

but if i just use command like below ...
java -Dcosbench.tomcat.config=conf/driver-tomcat-server.xml -server -cp main/org.eclipse.equinox.launcher_1.2.0.v20110502.jar org.eclipse.equinox.launcher.Main -configuration conf/.driver -console 18089 &
after start up。。。

i use “nc -i 1 0.0.0.0 18089” to open osgi
on osgi i use “ss -s ACTIVE cosbench”
i will see below plugins have been active

61      ACTIVE      cosbench-log_0.4.1.0
62      ACTIVE      cosbench-config_0.4.1.0
63      ACTIVE      cosbench-http_0.4.1.0
64      ACTIVE      cosbench-cdmi-util_0.4.1.0
65      ACTIVE      cosbench-tomcat_0.4.1.0
66      ACTIVE      cosbench-api_0.4.1.0
67      ACTIVE      cosbench-mock_0.4.1.0
68      ACTIVE      cosbench-ampli_0.4.1.0
69      ACTIVE      cosbench-swift_0.4.1.0
70      ACTIVE      cosbench-keystone_0.4.1.0
71      ACTIVE      cosbench-scality_0.4.1.0
72      ACTIVE      cosbench-swauth_0.4.1.0
73      ACTIVE      cosbench-httpauth_0.4.1.0
74      ACTIVE      cosbench-s3_0.4.1.0
75      ACTIVE      cosbench-librados_0.4.1.0
76      ACTIVE      cosbench-cdmi-base_0.4.1.0
77      ACTIVE      cosbench-cdmi-swift_0.4.1.0
78      ACTIVE      cosbench-core_0.4.1.0
79      ACTIVE      cosbench-driver_0.4.1.0
80      ACTIVE      cosbench-core-web_0.4.1.0
81      ACTIVE      cosbench-driver-web_0.4.1.0

so it work right ...
but now i still can‘t use start-all.sh , start-driver.sh , start-controller.sh to startup cosbench  ...
maybe the problem came from the system i use is not ubuntu ?

by now , without start-all.sh , start-driver.sh , start-controller.sh , i just create own shell script just directly use java open controller and driver without checking the plugins 。。。by the way it still can use cosbench ,and success to run cosbench too...

Thanks ,
Sky
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: cosbench failed to start on debian Jessie

ywang19
Administrator

Just removing the plugin checking should still work, and no relevant impact to following runs.

 

 

From: sky [via COSBench] [mailto:ml-node+[hidden email]]
Sent: Wednesday, August 12, 2015 10:59 PM
To: Wang, Yaguang
Subject: Re: cosbench failed to start on debian Jessie

 

Hi ywang
after change to -i 1 , will i run start-all.sh
it shows bellow
 
Booting cosbench driver ...
(UNKNOWN) [0.0.0.0] 18089 (?) : Connection refused

i guess that because the java haven't complete starting on port 18089 。。。
so i change then sleep 1 -> sleep 5
but now stuck on here

Launching osgi framwork ...
Successfully launched osgi framework!
Booting cosbench driver ...

so it look like still can’t fix the problem while using shell script to start up ...

but if i just use command like below ...
java -Dcosbench.tomcat.config=conf/driver-tomcat-server.xml -server -cp main/org.eclipse.equinox.launcher_1.2.0.v20110502.jar org.eclipse.equinox.launcher.Main -configuration conf/.driver -console 18089 &
after start up。。。

i use “nc -i 1 0.0.0.0 18089” to open osgi
on osgi i use “ss -s ACTIVE cosbench”
i will see below plugins have been active

61      ACTIVE      cosbench-log_0.4.1.0
62      ACTIVE      cosbench-config_0.4.1.0
63      ACTIVE      cosbench-http_0.4.1.0
64      ACTIVE      cosbench-cdmi-util_0.4.1.0
65      ACTIVE      cosbench-tomcat_0.4.1.0
66      ACTIVE      cosbench-api_0.4.1.0
67      ACTIVE      cosbench-mock_0.4.1.0
68      ACTIVE      cosbench-ampli_0.4.1.0
69      ACTIVE      cosbench-swift_0.4.1.0
70      ACTIVE      cosbench-keystone_0.4.1.0
71      ACTIVE      cosbench-scality_0.4.1.0
72      ACTIVE      cosbench-swauth_0.4.1.0
73      ACTIVE      cosbench-httpauth_0.4.1.0
74      ACTIVE      cosbench-s3_0.4.1.0
75      ACTIVE      cosbench-librados_0.4.1.0
76      ACTIVE      cosbench-cdmi-base_0.4.1.0
77      ACTIVE      cosbench-cdmi-swift_0.4.1.0
78      ACTIVE      cosbench-core_0.4.1.0
79      ACTIVE      cosbench-driver_0.4.1.0
80      ACTIVE      cosbench-core-web_0.4.1.0
81      ACTIVE      cosbench-driver-web_0.4.1.0

so it work right ...
but now i still can‘t use start-all.sh , start-driver.sh , start-controller.sh to startup cosbench  ...
maybe the problem came from the system i use is not ubuntu ?

by now , without start-all.sh , start-driver.sh , start-controller.sh , i just create own shell script just directly use java open controller and driver without checking the plugins 。。。by the way it still can use cosbench and success to run cosbench too...

Thanks
Sky


If you reply to this email, your message will be added to the discussion below:

http://cosbench.1094679.n5.nabble.com/cosbench-failed-to-start-on-debian-Jessie-tp404p409.html

To start a new topic under cosbench-user, email [hidden email]
To unsubscribe from COSBench, click here.
NAML

Loading...