Minimum and Maximum Supported JVM Versions

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Minimum and Maximum Supported JVM Versions

elijah
I'm putting together a PR for an adapter that supports Joyent's open source object store - Manta.

Currently, the latest version of the Java Manta driver is compiled in Java 1.8. When I look at the manifests for other plugins in COSBench, I see only references to:

Bundle-RequiredExecutionEnvironment: JavaSE-1.6

In order for the PR to be accepted, what version of Java should the adapter support as a maximum and as a minimum? My proof of concept now works fine with Java 1.8. If we can support that, it would be save me a lot of work backporting to 1.7 or even 1.6.

As per the Oracle documentation:
Java 1.6 had official support and updates end of lifed in February of 2011.
Java 1.7 had official support and updates end of lifed in March of 2014.

Would setting a minimum version of 1.8 make sense in this context?
Reply | Threaded
Open this post in threaded view
|

RE: Minimum and Maximum Supported JVM Versions

ywang19
Administrator

I see Java 1.8 introduces a few new grammar sugars, and still keep back-compatible with 1.6 and 1.7. we often used is 1.7, but no try on 1.8 with other adapters. A cut-off upgrade to 1.8 may bring broken. 1.6 seems too old, I noticed Ubuntu 14 LTS is still with java 1.7, so shifting to 1.7 as base should be fine. Could you just backport to 1.7 only?

 

 

From: elijah [via COSBench] [mailto:ml-node+[hidden email]]
Sent: Monday, December 21, 2015 6:58 AM
To: Wang, Yaguang
Subject: Minimum and Maximum Supported JVM Versions

 

I'm putting together a PR for an adapter that supports Joyent's open source object store - Manta.

Currently, the latest version of the Java Manta driver is compiled in Java 1.8. When I look at the manifests for other plugins in COSBench, I see only references to:

Bundle-RequiredExecutionEnvironment: JavaSE-1.6

In order for the PR to be accepted, what version of Java should the adapter support as a maximum and as a minimum? My proof of concept now works fine with Java 1.8. If we can support that, it would be save me a lot of work backporting to 1.7 or even 1.6.

As per the Oracle documentation:
Java 1.6 had official support and updates end of lifed in February of 2011.
Java 1.7 had official support and updates end of lifed in March of 2014.

Would setting a minimum version of 1.8 make sense in this context?


If you reply to this email, your message will be added to the discussion below:

http://cosbench.1094679.n5.nabble.com/Minimum-and-Maximum-Supported-JVM-Versions-tp432.html

To start a new topic under cosbench-developer, email [hidden email]
To unsubscribe from COSBench, click here.
NAML