Quantcast

COSbench on CentOS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

COSbench on CentOS

karan singh
Hi , i have recently started playing with COSbench and have tried several versions master branch, cosbench-0.4.2.c3 and cosbench-0.4.1.0 but could not get success in starting cosbench. Here is what i am getting
[centos@bench-node1 0.4.1]$ sh start-all.sh
Launching osgi framwork ...
Successfully launched osgi framework!
Booting cosbench driver ...
Ncat: Connection refused.
...........................................................
Starting    cosbench-log_0.4.1    [ERROR]
........................^C
[centos@bench-node1 0.4.1]$ ^C



[centos@bench-node1 0.4.1]$ cat log/driver-boot.log
Listening on port 0.0.0.0/0.0.0.0:18089 ...
!SESSION 2016-05-06 10:05:38.270 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Command-line arguments:  -console 18089

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.913
!MESSAGE Bundle plugins/cosbench-castor not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.915
!MESSAGE Bundle plugins/cosbench-log4j not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.916
!MESSAGE Bundle plugins/cosbench-log@6:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.917
!MESSAGE Bundle plugins/cosbench-config@6:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.923
!MESSAGE Bundle plugins/cosbench-http@6:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.924
!MESSAGE Bundle plugins/cosbench-cdmi-util@6:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.925
!MESSAGE Bundle plugins/cosbench-tomcat@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.927
!MESSAGE Bundle plugins/cosbench-api@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.928
!MESSAGE Bundle plugins/cosbench-mock@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.930
!MESSAGE Bundle plugins/cosbench-ampli@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.931
!MESSAGE Bundle plugins/cosbench-swift@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.932
!MESSAGE Bundle plugins/cosbench-keystone@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.934
!MESSAGE Bundle plugins/cosbench-scality@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.935
!MESSAGE Bundle plugins/cosbench-swauth@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.936
!MESSAGE Bundle plugins/cosbench-httpauth@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.937
!MESSAGE Bundle plugins/cosbench-s3@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.938
!MESSAGE Bundle plugins/cosbench-librados@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.939
!MESSAGE Bundle plugins/cosbench-cdmi-base@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.941
!MESSAGE Bundle plugins/cosbench-cdmi-swift@7:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.942
!MESSAGE Bundle plugins/cosbench-core@8:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.943
!MESSAGE Bundle plugins/cosbench-driver@8:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.944
!MESSAGE Bundle plugins/cosbench-core-web@8:start not found.

!ENTRY org.eclipse.osgi 4 0 2016-05-06 10:05:39.945
!MESSAGE Bundle plugins/cosbench-driver-web@8:start not found.
Persistence bundle starting...
Persistence bundle started.
log4j:WARN No appenders could be found for logger (org.springframework.osgi.extender.internal.boot.ChainActivator).
log4j:WARN Please initialize the log4j system properly.
[centos@bench-node1 0.4.1]$
Here are the sequence of commands i used 

$ wget https://github.com/intel-cloud/cosbench/archive/v0.4.1.0.zip
$ unzip v0.4.1.0.zip
$ ./pack.sh 0.4.1
$ cd 0.4.1/
$ sh start-all.sh

Packages such as nc , java , openJDK are installed. Please suggest how should i get it working.

Ports are listening 

[centos@bench-node1 0.4.1]$ nc 0.0.0.0 18089
osgi>
osgi> exit
^C
[centos@bench-node1 0.4.1]$

Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: COSbench on CentOS

ywang19
Administrator
please make sure binary package is in use instead of source package. the latest binary package is 0.4.2.c3 at https://github.com/intel-cloud/cosbench/releases/download/v0.4.2.c3/0.4.2.c3.zip .
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: COSbench on CentOS

karan singh
Thanks , using the correct binary package worked ;)
Loading...