Build Issues

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Build Issues

Vishnu
I was able to build 4.1.0, but i am having a ton of issues with 4.2.c4 with catalina.  Here is my log.. what am i doing wrong.. i recreated my whole environment from scratch and still missing something..

I have followed config.ini, and have no other bundles checked..


Persistence bundle starting...
Persistence bundle started.
Exception in thread "WebExtender-Init" java.lang.NoClassDefFoundError: org/apache/catalina/Container
        at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.createDefaultWarDeployer(WarListenerConfiguration.java:194)
        at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.<init>(WarListenerConfiguration.java:105)
        at org.springframework.osgi.web.extender.internal.activator.WarLoaderListener$1.run(WarLoaderListener.java:366)
        at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: org.apache.catalina.Container cannot be found by org.springframework.osgi.web_2.0.0.M1
        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:448)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:361)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:353)
        at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 4 more
----------------------------------------------
!!! Service will listen on web port: 19088 !!!
----------------------------------------------
!SESSION 2016-07-28 14:58:56.852 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_60
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Command-line arguments:  -dev file:/Users/vardhan/play/cosbenchv2/eclipse-workspace/.metadata/.plugins/org.eclipse.pde.core/controller/dev.properties -os macosx -ws cocoa -arch x86_64 -consoleLog -console

!ENTRY org.eclipse.osgi 4 0 2016-07-28 14:58:57.599
!MESSAGE Could not find bundle: org.eclipse.equinox.console
!STACK 0
org.osgi.framework.BundleException: Could not find bundle: org.eclipse.equinox.console
        at org.eclipse.core.runtime.internal.adaptor.ConsoleManager.checkForConsoleBundle(ConsoleManager.java:58)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:339)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:239)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:497)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Reply | Threaded
Open this post in threaded view
|

Re: Build Issues

Vishnu
Please ignore.. this worked.. i had not selected checked: **org.eclipse.osgi-3.7.0.v20110613.jar** because this was not in the config.ini file, where i was looking